为什么紫砂壶泡茶好:交换机基本配置2

来源:百度文库 编辑:我爱散文网 时间:2019/12/09 08:49:01
实验一 交换机基本配置
1.1实验目的:
1. 熟悉交换机的基本配置方式;
2. 熟悉交换机的命令行配置;
3. 配置交换机的常见功能:port trunk、link-aggregati
1.2 实验环境:
在实验中,我们采用华为新一代二层交换机s3026来组建实验环境。先组建第一套实验环境,完成交换机最基本的操作实验。然后两组学员共同组建第二套实验环境并完成交换机的功能配置实验。具体实验环境如下:

实验环境一

实验环境二
1.3 实验步骤:
1.3.1交换机的基本配置
c
用c
串口的配置参数如下:

单击确定按钮即可正常建立与交换机的通信。如果交换机已经启动,按enter键即可进入交换机的普通用户模式。若还没有启动,打开交换机电源我们会看到交换机的启动过程,启动完成后同样进入普通用户模式。
s3026交换机的配置相对于s2403发生了根本性变革,它采用功能强大,灵活方便的命令行配置方式。为了我们实验的顺利进行,先来介绍一下新一代交换机的几种配置模式:
普通用户模式:开机直接进入普通用户模式,在该模式下我们只能查询交换机的一些基础信息,如版本号(show versi
特权用户模式:在普通用户模式下输入enable命令即可进入特权用户模式,在该模式下我们可以查看交换机的配置信息和调试信息等等。
全局配置模式:在特权用户模式下输入c terminal命令即可进入全局配置模式,在该模式下主要完成全局参数的配置,具体配置在后面详细介绍。
接口配置模式:在全局配置模式下输入interface interface-list即可进入接口配置模式,在该模式下主要完成接口参数的配置,具体配置在后面详细介绍。
vlan配置模式:在全局配置模式下输入vlan vlan-number即可进入vlan配置模式下该配置模式下可以完成vlan的一些相关配置。
在使用命令行进行配置的时候,我们不可能完全记住所有的命令格式和参数,所以华为交换机为我们维护和工程人员提供了强有力的帮助功能,在任何模式下均可以使用“?”来帮助我们完成配置。使用“?”可以查询任何模式下可以使用的命令,或者某参数后面可以输入的参数,或者以某字母开始的命令。如在全局配置模式下输入“?”或“show ?”或“s?”,您看看它们分别有什么帮助信息显示。
telnet配置
如果交换机配置了ip地址,我们就可以在本地或者远程使用telnet登录到交换机上进行配置,和使用c
使用telnet的准备:
配置交换机的ip地址:s3026只支持一个ip地址,并且是作为vlan的接口ip地址出现的。所以,我们首先要在全局模式下使用interface vlan vlan-number命令进入vlan接口配置模式,然后使用ip address命令配置ip地址。
配置用户登录口令:在缺省情况下,交换机允许5个vty用户,但都没有配置登录口令。为了网络安全,华为交换机要求远程登录用户必须配置登录口令,否则不能登录。在全局配置模式下使用line vty 0 4进入line配置模式,然后使用password命令即可配置用户登录口令。
配置特权用户口令:远程登录用户要想进入特权用户模式,必须使用特权用户密码。在全局配置模式下使用enable password命令即可设置。
完成上述准备即可以通过telnet登录到交换机进行配置了。注意telnet连接属性设置如下:

恢复交换机的缺省配置
在实验时,为了不让实验受交换机以前的配置影响,我们常常需要先恢复交换机的缺省配置。在特权用户模式下顺序使用erase,restet命令即可恢复交换机的缺省配置。与此相反的是为了保证我们的配置在交换机重新启动之后不丢失,我们需要执行write命令把配置信息写入flash,重新启动交换机时就会应用flash中保存的配置来初始化交换机。
vlan配置
在实验环境一中,配置两个vlan:vlan1,vlan2。注意vlan1是交换机默认的vlan,既不能创建也不能删除,所有端口都属于vlan1。首先,创建vlan2,然后为各个vlan分配端口(switchport interface-list)即可。下面是完成上述配置后的配置信息:
quidway#show running-c
building running configuration...
current c is :
!
hostname quidway
!
interface aux0/0
!
vlan 1
!
vlan 2
!
interface ethernet0/1
switchport access vlan 1
!
interface ethernet0/10
switchport access vlan 2
!
interface ethernet0/11
switchport access vlan 2
!
interface ethernet0/12
switchport access vlan 2
!
interface ethernet0/13
switchport access vlan 1

……
!
interface null0
!
line aux 0
no login
line vty 0 4
!
end
如果您的配置确认无误后,用ping命令测试分别位于不同vlan的两台主机,看是否能相互通信?然后把其中两台主机移到同一个vlan中,再次测试彼此能够互通吗?知道vlan的作用了吗?vlan有隔离网络的作用,从而实现网络安全。
trunk端口
在上面的实验中,vlan只在一台交换机上实现,如果同一vlan的主机位于不同的交换机时,又有什么不同呢?让我们按照第二套实验环境来进行下面的实验。按图示组建环境,其中port2暂时不连接。在switch a上创建vlan2,vlan3,分别分配10-12,13-15端口,同时把port1配置成trunk口。在switch b上创建vlan2,vlan4,分别分配10-11,12-13端口,同时把port1配置成trunk口。完成上述配置之后测试两台主机是否能够相互通信?如果把两台主机都连接在交换机的其他没有人为分配vlan的端口(如port24),此时能够相互通信吗?知道为什么吗?
在交换机与交换机相连是,我们多采用trunk端口,但是trunk端口默认情况只允许vlan1的报文通过,所以出现了上面的实验现象。为了让连接在不同交换机而在同一vlan下的主机能够相互通信,我们必须配置switchport trunk allowed vlan all命令或者是switchport trunk allowed vlan vlan-number命令。在各交换机的trunk端口配置上述命令后,再测试连接在同一vlan下的主机能否相互通信?不同vlan下的主机呢?对于存在多个交换机多个vlan的局域网,我们手工注册来让trunk链路通过指定vlan报文是不现实的,所以需要用另一种动态注册协议应用(gvrp)来完成vlan的自动注册。具体配置在中级交换课程中再作详细介绍。
非trunk端口
如果交换机相连的端口不是trunk端口时又是什么情况呢?在刚才的实验基础上,取消port1的配置(no switchport trunk allowed vlan all,no switchport mode)后,此时再次测试一下网络通信状况,现象如何呢?此时port1也只能通过vlan1,所以同在vlan2不同交换机下的主机不能通信。这是因为非trunk端口只能通过缺省vlan id所指示的报文,为了让非trunk端口能通过其它vlan数据包,我们可以执行tagged valn vlan-number命令来实现。在交换机的port1上执行相应命令使其能够通过vlan2,vlan3,vlan4的数据包。然后此时同在vlan2下任意两台主机应该能够正常通信了。
spanning-tree功能
如果我们把环境二中的port2也连接起来,与port1作同样的配置后,在主机上用ping命令测试两台主机的通信状况,此时有什么现象。是不是看见交换机的几个工作端口的指示灯不停的闪动呢?这就是局域网中常见的广播风暴。广播风暴是因为在网络中间形成了环路。那么我们怎样才能避免呢?在此我们有两种方法:一、启用交换机的生成树功能;二、对于此种特殊情况可以用端口聚合来解决,实际上端口聚合主要目的使增加网络连接带宽的,避免在交换机与交换机连接时产生瓶颈。
我们先来研究一下生成树。在此不详述生成树的原理,只讨论华为交换机上生成树的具体配置。要抑制广播风暴,我们只需要在全局配置模式下启用生成树功能(spanning-tree enable)即可。此时还有广播风暴存在吗?还有一些优化网络性能的配置参数,如优先级,hello-time等。这些参数的具体含义和配置在中级交换课程中会有详细介绍,在此不作要求。另外,此处我们连接交换机使用的是两个非trunk端口,实际组网时都使用trunk端口,那么使用trunk端口也是否存在广播风暴呢?您可以根据前面的实验来设计并完成该实验,其答案是肯定的。具体操作如下:
1. 在前面的基础上取消tagged命令(no tagged);
2. 设置port1、port2为trunk端口并允许所有vlan报文通过。
端口聚合(link-aggregation)
为了增加交换机之间连接带宽,我们常常需要把多个端口捆绑起来等同于一个物理端口应用,避免网络瓶颈。对于本实验我们只需在全局配置模式下完成如下配置即可:
link-aggregation ethernet0/1 to ethernet0/2 ingress-egress
具体配置信息如下:
switchb# show running-c
building running configuration...
current c is :
!
hostname switchb
spanning-tree enable
!
interface aux0/0
!
vlan 1
!
vlan 2
!
vlan 4
!
interface ethernet0/1
switchport mode trunk
switchport trunk allowed vlan all
!
interface ethernet0/10
switchport access vlan 2
!
interface ethernet0/11
switchport access vlan 2
!
interface ethernet0/12
switchport access vlan 4
!
interface ethernet0/13
switchport access vlan 4
!
……
interface ethernet0/2
switchport mode trunk
switchport trunk allowed vlan all
!
interface ethernet0/20
……
!
interface null0

link-aggregation ethernet0/1 to ethernet0/2 ingress-egress
!
line aux 0
no login
line vty 0 4
!
end
另一交换机的配置类似。现在还有广播风暴存在吗?
完成上述实验,我们可以总结一下,在今天的实验课程中所涉及的交换知识,主要有vlan,spanning-tree,link-aggregati
本文出自 51CTO.COM技术博客